Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2002-251: apache


Vulnerability Assessment Details

RHSA-2002-251: apache

Vulnerability Assessment Summary
Check for the version of the apache packages

Detailed Explanation for this Vulnerability Assessment


Updated apache and httpd packages are available which fix a number of
security issues for Red Hat Linux Advanced Server 2.1.

[Updated 06 Feb 2003]
Added fixed packages for Advanced Workstation 2.1

The Apache HTTP server is a powerful, full-featured, efficient, and
freely-available Web server.

Buffer overflows in the ApacheBench support program (ab.c) in Apache
versions prior to 1.3.27 permit a malicious Web server to cause a denial of
service and possibly execute arbitrary code via a long response. The
Common Vulnerabilities and Exposures project has assigned the name
CVE-2002-0843 to this issue.

Two cross-site scripting vulnerabilities are present in the error pages
for the default "404 Not Found" error, and for the error response when a
plain HTTP request is received on an SSL port. Both of these issues are
only exploitable if the "UseCanonicalName" setting has been changed to
"Off", and wildcard DNS is in use. These issues would permit remote
attackers to execute scripts as other Web page visitors, for instance, to
steal cookies. These issues affect versions of Apache 1.3 before 1.3.26,
and versions of mod_ssl before 2.8.12. The Common Vulnerabilities and
Exposures project has assigned the names CVE-2002-0840 and CVE-2002-1157 to
these issues.

The shared memory scoreboard in the HTTP daemon for Apache 1.3, prior to
version 1.3.27, permited a user running as the "apache" UID to send a
SIGUSR1 signal to any process as root, resulting in a denial of service
(process kill) or other such behavior that would not normally be permited.
The Common Vulnerabilities and Exposures project has assigned the name
CVE-2002-0839 to this issue.

All users of the Apache HTTP server are advised to upgrade to the
applicable errata packages. For Red Hat Linux Advanced Server 2.1 these
packages include Apache version 1.3.27 which is not vulnerable to
these issues.

Note that the instructions in the "Solution" section of this errata contain
additional steps required to complete the upgrade process.




Solution : http://rhn.redhat.com/errata/RHSA-2002-251.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Dell PowerEdge R710 2x X5660 2.8GHz 6 Core 48GB 6x 3TB 7.2K SAS PERC H700
$1375.0
Dell PowerEdge R710 2x X5660 2.8GHz 6 Core 48GB 6x 3TB 7.2K SAS PERC H700 pictureMicrosoft Windows 2008 Server DSP OEM with Memory 5-Client 4CPU 86-bit 32-bit
$54.99
Microsoft Windows 2008 Server DSP OEM with Memory 5-Client 4CPU 86-bit 32-bit pictureSQL Server 2005, Standard Edition Part #x11-54700
$129.0
SQL Server 2005, Standard Edition Part #x11-54700 pictureDELL POWEREDGE R710 SERVER 2 x 2.8GHz HEX,8X8GB,3X146G 10K,H700 1GB,DRAC,2XPSU
$250.0
DELL POWEREDGE R710 SERVER 2 x 2.8GHz HEX,8X8GB,3X146G 10K,H700 1GB,DRAC,2XPSU picture


Discussions

No Discussions have been posted on this vulnerability.