Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2002-214: php


Vulnerability Assessment Details

RHSA-2002-214: php

Vulnerability Assessment Summary
Check for the version of the php packages

Detailed Explanation for this Vulnerability Assessment


PHP versions up to and including 4.2.2 contain vulnerabilities in the mail
()
function, permiting local script authors to bypass safe mode restrictions
and possibly permiting remote attackers to insert arbitrary mail headers or
content.

[Updated 13 Jan 2003]
Added fixed packages for the Itanium (IA64) architecture.

[Updated 06 Feb 2003]
Added fixed packages for Advanced Workstation 2.1

PHP is an HTML-embedded scripting language commonly used with the Apache
HTTP server.

The mail function in PHP 4.x to 4.2.2 may permit local script authors to
bypass safe mode restrictions and modify command line arguments to the
MTA (such as sendmail) in the 5th argument to mail(), altering MTA
behavior and possibly executing arbitrary local commands.

The mail function in PHP 4.x to 4.2.2 does not filter ASCII control
characters from its arguments, which could permit remote attackers to
modify mail message content, including mail headers, and possibly use
PHP as a "spam proxy."

Script authors should note that all input data should be checked for
unsafe data by any PHP scripts which call functions such as mail().

Note that this PHP errata, as did RHSA-2002:129, enforces memory limits on
the size of the PHP process to prevent a badly generated script from
becoming a possible source for a denial of service attack. The default
process size is 8Mb, though you can adjust this as you deem necessary
through the php.ini directive memory_limit. For example, to change the
process memory limit to 4MB, add the following:

memory_limit 4194304

Important Note:
There are special instructions you should follow regarding your
/etc/php.ini configuration file in the "Solution" section below.




Solution : http://rhn.redhat.com/errata/RHSA-2002-214.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

DELL OPTIPLEX 7010 MT PC CORE I5-3570 @ 3.40GHZ 8GB RAM 1.0TB HDD / T1*A14
$135.0
DELL OPTIPLEX 7010 MT PC CORE I5-3570 @ 3.40GHZ 8GB RAM 1.0TB HDD / T1*A14 pictureAMD Quad-Core A8-3510MX AM3510HLX43GX 1.8 GHz Socket FS1 notebook APU CPU
$51.99
AMD Quad-Core A8-3510MX AM3510HLX43GX 1.8 GHz Socket FS1 notebook APU CPU pictureTS-251+-8G 2-bay 8GB RAM QNAP TS-251+ (8GB RAM version) 2-Bay Next Gen Quad-Core
$499.95
TS-251+-8G 2-bay 8GB RAM QNAP TS-251+ (8GB RAM version) 2-Bay Next Gen Quad-Core pictureHP Slimline SFF 260-a020 A6-7310 Quad Core 2.0GHz 6GB RAM 1TB HD Win 10 Home
$199.5
HP Slimline SFF 260-a020 A6-7310 Quad Core 2.0GHz 6GB RAM 1TB HD Win 10 Home  picture


Discussions

No Discussions have been posted on this vulnerability.