Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2002-170: ethereal


Vulnerability Assessment Details

RHSA-2002-170: ethereal

Vulnerability Assessment Summary
Check for the version of the ethereal packages

Detailed Explanation for this Vulnerability Assessment


Updated ethereal packages are available which fix several security problems.

Ethereal is a package designed for monitoring network traffic on your
system. Several security issues have been found in the Ethereal packages
distributed with Red Hat Linux Advanced Server:

Buffer overflow in Ethereal 0.9.5 and earlier permits remote attackers to
cause a denial of service or execute arbitrary code via the ISIS dissector.
(CVE-2002-0834)

Buffer overflows in Ethereal 0.9.4 and earlier permits remote attackers
to cause a denial of service or execute arbitrary code via (1) the BGP
dissector, or (2) the WCP dissector. (CVE-2002-0821)

Ethereal 0.9.4 and earlier permits remote attackers to cause a denial
of service and possibly excecute arbitrary code via the (1) SOCKS, (2)
RSVP, (3) AFS, or (4) LMP dissectors, which can be caused to core
dump (CVE-2002-0822)

A buffer overflow in the X11 dissector in Ethereal before 0.9.4 permits
remote attackers to cause a denial of service (crash) and possibly
execute arbitrary code while Ethereal is parsing keysyms. (CVE-2002-0402)

The DNS dissector in Ethereal before 0.9.4 permits remote attackers to
cause a denial of service (CPU consumption) via a malformed packet
that causes Ethereal to enter an infinite loop. (CVE-2002-0403)

A vulnerability in the GIOP dissector in Ethereal before 0.9.4 permits
remote attackers to cause a denial of service (memory consumption).
(CVE-2002-0404)

Users of Ethereal should update to the errata packages containing Ethereal
version 0.9.6 which is not vulnerable to these issues.




Solution : http://rhn.redhat.com/errata/RHSA-2002-170.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

HP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 8GB 1TB MIDLINE
$789.0
HP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 8GB 1TB MIDLINE pictureHP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 16GB 3 X 1TB MIDLINE
$1199.0
HP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 16GB 3 X 1TB MIDLINE pictureHP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 4GB 1TB MIDLINE
$749.0
HP PROLIANT MICROSERVER G8 E3-1220LV2 2.3GHZ 4GB 1TB MIDLINE pictureLantronix MSS-100 Fast Ethernet Micro Serial Server With Power Supply Free S/H
$29.95
Lantronix MSS-100 Fast Ethernet Micro Serial Server With Power Supply Free S/H  picture


Discussions

No Discussions have been posted on this vulnerability.