Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Red Hat Local Security Checks >> RHSA-2002-129: php


Vulnerability Assessment Details

RHSA-2002-129: php

Vulnerability Assessment Summary
Check for the version of the php packages

Detailed Explanation for this Vulnerability Assessment


PHP versions earlier than 4.1.0 contain a vulnerability that could permit
arbitrary commands to be executed.

[updated 22 Aug 2002]
The initial set of errata packages contained an incorrect set of
dependencies. This meant that a number of packages would need to be
installed before php that were not essential to the operation of php.
Updated errata packages are included with this advisory that have corrected
dependencies.

PHP is an HTML-embedded scripting language commonly used with Apache. PHP
versions 4.0.5 through 4.1.0 in safe mode do not properly cleanse the 5th
parameter to the mail() function. This vulnerability permits local users and
possibly remote attackers to execute arbitrary commands via shell
metacharacters.

Red Hat Linux Advanced Server version 2.1 shipped with PHP 4.0.6.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2001-1246 to this issue.

All users of PHP should upgrade to these errata packages containing PHP
4.1.2, which is not vulnerable to this issue.

Note:

This PHP errata enforces memory limits on the size of the PHP process to
prevent a badly generated script from becoming a possible source for a
denial of service attack. The default process size is 8Mb though you can
adjust this as you deem necessary thought the php.ini directive
memory_limit. For example, to change the process memory limit to 4MB, add
the following:

memory_limit 4194304

Important Installation Note:

There are special instructions you should follow regarding your
/etc/php.ini configuration file in the "Solution" section below.




Solution : http://rhn.redhat.com/errata/RHSA-2002-129.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

8GB G.Skill 2133MHz DDR4 SO-DIMM Memory Module (CL15) 1.20V PC4-17000 Ripjaws
$60.0
8GB G.Skill 2133MHz DDR4 SO-DIMM Memory Module (CL15) 1.20V PC4-17000 Ripjaws pictureHynix 2 GB 2Rx8 PC2-6400S-666-12 Memory (HYMP125S64CP8S6ABC)
$9.99
Hynix 2 GB 2Rx8 PC2-6400S-666-12 Memory (HYMP125S64CP8S6ABC) pictureApple MacBook Pro Laptop w/ OS X 10.11 + Intel Core i5 CPU @ 2.6 Ghz, 8 GB Ram,
$699.99
Apple MacBook Pro Laptop w/ OS X 10.11 + Intel Core i5 CPU @ 2.6 Ghz, 8 GB Ram,  pictureCORSAIR Value Select 1GB DDR-400 PC3200 CL3 RAM VS1GB400C3 NEW - IN PACKAGE
$3.48
CORSAIR Value Select 1GB DDR-400 PC3200 CL3 RAM VS1GB400C3 NEW - IN PACKAGE picture


Discussions

No Discussions have been posted on this vulnerability.