Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PunBB language Paramater Local File Include Vulnerability


Vulnerability Assessment Details

PunBB language Paramater Local File Include Vulnerability

Vulnerability Assessment Summary
Tries to read a local file with PunBB

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is affected by a
local file include issue.

Description:

The version of PunBB installed on the remote host fails to sanitize
input to the 'language' parameter before storing it in the
'register.php' script as a user's preferred language setting. By
registering with a specially-crafted value, a possible hacker can leverage
this issue to view arbitrary files and possibly execute arbitrary code
on the affected host.

See also :

http://www.securityfocus.com/archive/1/450055/30/0/threaded
http://forums.punbb.org/viewtopic.php?id=13496

Solution :

Update to version 1.2.14 or later.

Network Security Threat Level:

High / CVSS Base Score : 7
(AV:R/AC:L/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 20786

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Justin Seitz

Cables, Connectors

Juniper Networks Netscreen 50
$0.3
Juniper Networks Netscreen 50 pictureBSF300a
$0.3
BSF300a pictureWATCHGUARD TRADEUP HA WGT70693-US COMP T/U T70 3YR TOTAL SEC US
$4048.3
WATCHGUARD TRADEUP HA WGT70693-US  COMP T/U T70 3YR TOTAL SEC US picture Cisco PIX-515E Network Firewall Appliances with Network Card
$18.0
 Cisco PIX-515E Network Firewall Appliances with Network Card picture


Discussions

No Discussions have been posted on this vulnerability.