Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PunBB < 1.2.8 Multiple Vulnerabilities


Vulnerability Assessment Details

PunBB < 1.2.8 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in PunBB < 1.2.8

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains two PHP scripts that may permit arbitrary
code execution, local file disclosure, and cross-site scripting attacks.

Description :

According to its banner, the version of PunBB installed on the remote
host suffers from several flaws.

- A File Include Vulnerability
The application fails to validate the 'language'
parameter when a user updates his profile and uses that
throughout the application to require PHP code in order
to display messages. A possible hacker with an account on the
affected application may be able to exploit this issue
to read arbitrary and even to execute local files with
arbitrary PHP code subject to the rights of the web
server user id.

- A Cross-Site Scripting Vulnerability
The application also does not sanitize input passed to
the 'email' parameter of the 'login.php' script when
requesting a new password, which permits cross-site
scripting attacks such as theft of authentication
cookies.

See also :

http://www.punbb.org/changelogs/1.2.7_to_1.2.8.txt

Solution :

Upgrade to PunBB 1.2.8 or later.

Network Security Threat Level:

Low / CVSS Base Score : 3
(AV:R/AC:H/Au:R/C:P/A:P/I:P/B:N)

Networks Security ID: 14900, 14904

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

EMC Dell Recoverypoint Gen4 R610 Server 100-562-779 2x Xeon E5504 2GHz 8GB
$79.99
EMC Dell Recoverypoint Gen4 R610 Server 100-562-779 2x Xeon E5504 2GHz 8GB pictureDELL POWEREDGE R730 8 BAY E5-2650LV3 1.8GHZ 64GB 5 X 600GB 10K 12G H730
$3729.0
DELL POWEREDGE R730 8 BAY E5-2650LV3 1.8GHZ 64GB 5 X 600GB 10K 12G H730 pictureDELL POWEREDGE R730 8 BAY E5-2650V3 2.3GHZ 96GB 7 X 1.6TB SSD SAS H730
$13549.0
DELL POWEREDGE R730 8 BAY E5-2650V3 2.3GHZ 96GB 7 X 1.6TB SSD SAS H730 pictureDELL POWEREDGE R730 8 BAY E5-2630V3 2.4GHZ 64GB 5 X 1TB SATA H730
$2779.0
DELL POWEREDGE R730 8 BAY E5-2630V3 2.4GHZ 64GB 5 X 1TB SATA H730 picture


Discussions

No Discussions have been posted on this vulnerability.