Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Windows >> PuTTY Multiple Integer Overflow Vulnerablities


Vulnerability Assessment Details

PuTTY Multiple Integer Overflow Vulnerablities

Vulnerability Assessment Summary
PuTTY version check

Detailed Explanation for this Vulnerability Assessment

The remote host is using PuTTY, a free SSH client.

The remote version of this software is vulnerable to various integer overflow
vulnerabilities which may permit a possible hacker to execute arbitrary code on the remote
host.

To exploit these vulnerabilities, a possible hacker would need to set up a rogue SSH
daemon and lure a victim on the remote host into connecting to it using PuTTY.

Solution : Upgrade to PuTTY 0.57 or newer
Network Security Threat Level: High

Networks Security ID: 12601

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

H61 motherboard set kit LGA 1155 with Intel I5 2500 processor 16GB DDR3 memory
$174.78
H61 motherboard set kit LGA 1155 with Intel I5 2500  processor 16GB DDR3 memory  pictureHigh Speed Mini USB 2.0 Micro SD TF T-Flash Memory Card Reader Adapter
$9.48
High Speed Mini USB 2.0 Micro SD TF T-Flash Memory Card Reader Adapter picture2PCS USB 2.0 Micro SD SDHC TF Flash Memory Card Reader Mini Adapter For Laptop
$9.56
2PCS USB 2.0 Micro SD SDHC TF Flash Memory Card Reader Mini Adapter For Laptop pictureSamsung 1GB Memory Ram PC 1RX8 PC2 6400U-666-12 M378T2863QZS-CF7 Used DDR2 SDRAM
$3.0
Samsung 1GB Memory Ram PC 1RX8 PC2 6400U-666-12 M378T2863QZS-CF7 Used DDR2 SDRAM picture


Discussions

No Discussions have been posted on this vulnerability.