Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Firewalls >> Proxy accepts gopher:// requests


Vulnerability Assessment Details

Proxy accepts gopher:// requests

Vulnerability Assessment Summary
Acertains if we can use the remote web proxy to do gopher requests

Detailed Explanation for this Vulnerability Assessment

The proxy accepts gopher:// requests.

Gopher is an old network protocol which predates HTTP and
is nearly unused today. As a result, gopher-compatible
software is generally less audited and more likely to contain
security bugs than others.

By making gopher requests, a possible hacker may evade your firewall
settings, by making connections to port 70, or may even exploit
arcane flaws in this protocol to gain more rights on this
host (see the attached CVE id for such an example).

Solution : reconfigure your proxy so that it refuses gopher requests.
Network Security Threat Level: Medium

Networks Security ID: 4930

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

IBM 174724X-B99 IBM IBM System Storage EXP2524 Express Storage Enclosure (No Rai
$267.0
IBM 174724X-B99 IBM IBM System Storage EXP2524 Express Storage Enclosure (No Rai pictureIBM 7870B3U-C15 IBM.Server BladeCenter HS22 Xeon Quad-Core 2.40 GHz Bus Speed: 5
$147.0
IBM 7870B3U-C15 IBM.Server BladeCenter HS22 Xeon Quad-Core 2.40 GHz Bus Speed: 5 pictureIBM 7870AC1-C146 IBM.Server BladeCenter HS22 2 x Xeon Quad-Core 2.53 GHz Bus Spe
$125.0
IBM 7870AC1-C146 IBM.Server BladeCenter HS22 2 x Xeon Quad-Core 2.53 GHz Bus Spe pictureIBM 7870AC1-C144 IBM.Server BladeCenter HS22 2 x Xeon Quad-Core 2.93 GHz Bus Spe
$125.0
IBM 7870AC1-C144 IBM.Server BladeCenter HS22 2 x Xeon Quad-Core 2.93 GHz Bus Spe picture


Discussions

No Discussions have been posted on this vulnerability.