Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> FTP >> ProFTPd ASCII upload overflow


Vulnerability Assessment Details

ProFTPd ASCII upload overflow

Vulnerability Assessment Summary
Checks the remote ProFTPD version

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of ProFTPd which seems
to be vulnerable to a buffer overflow when a user downloads
a malformed ASCII file.

A possible hacker with upload rights on this host may abuse this
flaw to gain a root shell on this host.

*** The author of ProFTPD did not increase the version number
*** of his product when fixing this issue, so it might be false
*** positive.

Solution : Upgrade to ProFTPD 1.2.9 when available or to 1.2.8p
Network Security Threat Level: High

Networks Security ID: 8679

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Tenable Network Security

Cables, Connectors

HP Pavilion Dv6 Notebook PC ~ Intel (R) Core(TM)2 Duo CPU ~ P7450 @ 2.13 GHz 4GB
$48.0
HP Pavilion Dv6 Notebook PC ~ Intel (R) Core(TM)2 Duo CPU ~ P7450 @ 2.13 GHz 4GB pictureIntel Core i3-3220 3.3GHz Dual-Core Processor
$3.73
Intel Core i3-3220 3.3GHz Dual-Core Processor pictureIntel Core i5-4590 3.3GHz Quad-Core (BX80646I54590) Processor
$63.0
Intel Core i5-4590 3.3GHz Quad-Core (BX80646I54590) Processor picture


Discussions

No Discussions have been posted on this vulnerability.