Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Databases >> PostgreSQL to_ascii() overflow


Vulnerability Assessment Details

PostgreSQL to_ascii() overflow

Vulnerability Assessment Summary
Attempts to log into the remote PostgreSQL daemon

Detailed Explanation for this Vulnerability Assessment

The remote PostgreSQL server, according to its version number,
is vulnerable to a buffer overflow in the to_ascii() function,
which may permit a possible hacker who has the rights to query the remote
database to obtain a shell on this host.

Solution : Upgrade to postgresql 7.3.4 or newer
Network Security Threat Level: High

Networks Security ID: 8741

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

Knoppix 7.2.0 Live Linux Bootable Startup CD (Runs form CD) +Free Retro Linux CD
$11.95
Knoppix 7.2.0 Live Linux Bootable Startup CD (Runs form CD) +Free Retro Linux CD pictureKNOPPIX 8.1 LINUX LIVE DVD - 2018
$6.99
KNOPPIX 8.1 LINUX LIVE DVD - 2018 pictureKnoppix Linux , 32 Bit
$5.99
Knoppix Linux , 32 Bit pictureKNOPPIX 8.1 LINUX LIVE DVD - 2018
$5.95
KNOPPIX 8.1 LINUX LIVE DVD - 2018 picture


Discussions

No Discussions have been posted on this vulnerability.