Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Databases >> PostgreSQL Character Conversion and Tsearch2 Module Vulnerabilities


Vulnerability Assessment Details

PostgreSQL Character Conversion and Tsearch2 Module Vulnerabilities

Vulnerability Assessment Summary
Checks for character conversion and tsearch2 module vulnerabilities in PostgreSQL

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote database server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of PostgreSQL installed on the
remote host may suffer from the following vulnerabilities :

- Character Conversion Vulnerability
Unprivileged users can call functions supporting client-
server character set conversion from SQL commands even
though those functions do not validate their arguments.

- tsearch2 Vulnerability
If installed, the 'contrib/tsearch2' module permits users
to at a minimum crash the backend because it misdeclares
several functions as returning type 'internal' when in
fact they do not have any 'internal' argument.

See also:

http://www.postgresql.org/about/news.315
http://developer.postgresql.org/docs/postgres/release-8-0-3.html

Solution :

Implement the changes described in the PostgreSQL advisory.

Network Security Threat Level:

Medium / CVSS Base Score : 4
(AV:R/AC:L/Au:R/C:P/A:P/I:P/B:N)

Networks Security ID: 13475, 13476

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Tsmine Verizon 10" USA Flag News Paper Rotating Case - Universal Vintage Retro P
$18.16
Tsmine Verizon 10Leather iPad Cases And Covers Vintage Genuine Handcrafted Protection Secure NEW
$80.95
Leather iPad Cases And Covers Vintage Genuine Handcrafted Protection Secure NEW pictureCellini Bordeaux Belting leather Briefcase Burgundy Vintage Framed
$80.99
Cellini Bordeaux Belting leather Briefcase Burgundy Vintage Framed pictureVintage Software Photoshop Elements 3.0 Used 12642-4
$5.99
Vintage Software Photoshop Elements 3.0 Used 12642-4 picture


Discussions

No Discussions have been posted on this vulnerability.