Vulnerability Assessment & Network Security Forums

If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.

Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PmWiki < 2.1.21 Global Variables Overwrite Vulnerability

Vulnerability Assessment Details

PmWiki < 2.1.21 Global Variables Overwrite Vulnerability

Vulnerability Assessment Summary
Checks for a remote file include flaw in PmWiki

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is affected by a
global variable overwriting vulnerability.

Description :

The version of PmWiki installed on the remote host contains a
programming flaw in 'pmwiki.php' that may permit an unauthenticated
remote attacker to overwrite global variables used by the application,
which could in turn be exploited to execute arbitrary PHP code on the
affected host, subject to the rights of the web server user id.

Note that successful exploitation of this issue requires that PHP's
'register_globals' and 'file_uploads' settings be enabled and that the
remote version of PHP be older than 4.4.3 or 5.1,4.

See also :

Solution :

Upgrade to PmWiki version 2.1.21 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 4.9

Networks Security ID: 17843

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors


No Discussions have been posted on this vulnerability.