Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Plume CMS <= 1.0.2 Remote File Inclusion Vulnerability


Vulnerability Assessment Details

Plume CMS <= 1.0.2 Remote File Inclusion Vulnerability

Vulnerability Assessment Summary
Check if Plume CMS is vulnerable to a file inclusion flaw

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote host is running a PHP application that is prone
to local and remote file inclusion attacks.

Description :

The system is running Plume CMS a simple but powerful
content management system.

The version installed does not sanitize user input in the
'_PX_config[manager_path]' parameter in the 'prepend.php' file.
This permits a possible hacker to include arbitrary files and execute code
on the system.

This flaw is exploitable if PHP's register_globals is enabled.

See also :

http://www.plume-cms.net/news/77-Security-Notice-Please-Update-Your-Prependphp-File
http://secunia.com/advisories/18883/

Solution :

Either sanitize the prepend.php
file as advised by the developer (see first URL) or
upgrade to Plume CMS version 1.0.3 or later

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 16662

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Ferdy Riphagen

Cables, Connectors

Cisco CP-PWR-CUBE-3 VoIP Telephone Power Adapters
$27.0
Cisco CP-PWR-CUBE-3 VoIP Telephone Power Adapters pictureCisco 72-3383-01 DB9M to RJ-45 console cable
$18.0
Cisco 72-3383-01 DB9M to RJ-45 console cable pictureCisco AIR-PWRINJ3 - 48V DC Power Injector
$35.0
Cisco AIR-PWRINJ3 - 48V DC Power Injector pictureCisco 2610 CISCO2610 Modular Router
$125.0
Cisco 2610 CISCO2610 Modular Router picture


Discussions

No Discussions have been posted on this vulnerability.