Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PatchLink Update checkid SQL Injection Vulnerability


Vulnerability Assessment Details

PatchLink Update checkid SQL Injection Vulnerability

Vulnerability Assessment Summary
Tries to exploit SQL injection issue in PatchLink Update

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains an ASP script that is prone to a SQL
injection attack.

Description :

The remote host is running PatchLink Update Server, a patch and
vulnerability management solution.

The version of PatchLink Update Server installed on the remote fails
to sanitize user-supplied input to the 'agentid' parameter of the
'/dagent/checkprofile.php' script before using it to construct
database queries. An unauthenticated attacker can exploit this flaw
to manipulate database queries, which might lead to disclosure of
sensitive information, modification of data, or attacks against the
underlying database.

Note that Novell ZENworks Patch Management is based on PatchLink
Update Server and is affected as well.

See also :

http://www.securityfocus.com/archive/1/438710/30/0/threaded
http://support.novell.com/cgi-bin/search/searchtid.cgi?10100709.htm

Solution :

Apply patch 6.1 P1 / 6.2 SR1 P1 if using PatchLink Update Server or
6.2 SR1 P1 if using Novell ZENworks Patch Management.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 18715

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

DELL POWEREDGE R730 LFF 8 BAY E5-2699V3 2.3GHZ 192GB 5 X 146GB 15K SAS H330
$10179.0
DELL POWEREDGE R730 LFF 8 BAY E5-2699V3 2.3GHZ 192GB 5 X 146GB 15K SAS H330 pictureDELL POWEREDGE R730 8 BAY E5-2630V4 2.2GHZ 32GB 4 X 1TB SAS H730
$3999.0
DELL POWEREDGE R730 8 BAY E5-2630V4 2.2GHZ 32GB 4 X 1TB SAS H730 pictureDELL POWEREDGE R730 8 BAY TWO E5-2699V4 2.2GHZ 512GB 2 X 500GB SAS H730
$17149.0
DELL POWEREDGE R730 8 BAY TWO E5-2699V4 2.2GHZ 512GB 2 X 500GB SAS H730 pictureDell PowerEdge R610 2x X5670 2.93GHz 6 Core 16GB 6x 146GB 15K SAS PERC 6/i
$775.0
Dell PowerEdge R610 2x X5670 2.93GHz 6 Core 16GB 6x 146GB 15K SAS PERC 6/i picture


Discussions

No Discussions have been posted on this vulnerability.