Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PWSPHP XSS


Vulnerability Assessment Details

PWSPHP XSS

Vulnerability Assessment Summary
Checks XSS in PWSPHP

Detailed Explanation for this Vulnerability Assessment

The remote host runs PWSPHP (Portail Web System) a CMS written in PHP.

The remote version of this software is vulnerable to cross-site
scripting attack due to a lack of sanity checks on the 'skin' parameter
in the script SettingsBase.php.

With a specially crafted URL, a possible hacker could use the remote server
to set up a cross site script attack.

Solution: Upgrade to version 1.2.3 or newer
Network Security Threat Level: Medium

Networks Security ID: 13561, 13563

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 David Maciejak

Cables, Connectors

Atari Computer Donkey Kong Cartridge & Manual 400/800/XL/XE
$9.99
Atari Computer Donkey Kong Cartridge & Manual 400/800/XL/XE  pictureRare 1984 BASIC XL OSS Cartridge for Atari 400/800/XL/XE Computer
$99.99
Rare 1984 BASIC XL OSS Cartridge for Atari 400/800/XL/XE Computer pictureAtari 850 Interface Unit in Box
$59.99
Atari 850 Interface Unit in Box pictureVintage ATARI 130XE Computer Protective Dust Cover
$29.99
Vintage ATARI 130XE Computer Protective Dust Cover picture


Discussions

No Discussions have been posted on this vulnerability.