Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PHPix directory traversal vulnerability


Vulnerability Assessment Details

PHPix directory traversal vulnerability

Vulnerability Assessment Summary
PHPix directory traversal vulnerability

Detailed Explanation for this Vulnerability Assessment
PHPix program permits a possible hacker to read arbitrary files on the remote web server, prefixing the pathname of the file with ..%2F..%2F..

Example:
GET /Album/?mode=album&album=..%2F..%2F..%2F..%2F..%2F..%2F..%2F..%2Fetc&dispsize=640&start=0

will return all the files that are nested within /etc directory.

Solution: Contact your vendor for the latest software release.

Network Security Threat Level: High

Networks Security ID: 1773

Vulnerability Assessment Copyright: This script is Copyright (C) 2000 Zorgon

Cables, Connectors

Dell PowerEdge R720 Server | 2X E5-2640 | 128GB RAM | H310 | 8 Bay
$300.0
Dell PowerEdge R720 Server | 2X E5-2640 | 128GB RAM | H310 | 8 Bay pictureDell Poweredge R620 2 x EIGHT CORE 2.40GHZ E5-2665 64GB MEMORY 4 x 146GB QTY AV
$9.99
Dell Poweredge R620 2 x EIGHT CORE 2.40GHZ E5-2665 64GB MEMORY 4 x 146GB QTY AV pictureDell PowerEdge R510: 2x Intel Xeon 6-Core X5670 @ 2.93GHz 16GB DDr3 Perc H700~
$0.74
Dell PowerEdge R510: 2x Intel Xeon 6-Core X5670 @ 2.93GHz 16GB DDr3 Perc H700~ pictureDELL PowerEdge R510 Server 2×Six-Core Xeon 2.8GHz + 128GB RAM + 12×2TB SAS RAID
$933.33
DELL PowerEdge R510 Server 2×Six-Core Xeon 2.8GHz + 128GB RAM + 12×2TB SAS RAID picture


Discussions

No Discussions have been posted on this vulnerability.