Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PHPNews sendtofriend.php SQL injection


Vulnerability Assessment Details

PHPNews sendtofriend.php SQL injection

Vulnerability Assessment Summary
Makes a request to the remote host by supplying the mid paramter in the url

Detailed Explanation for this Vulnerability Assessment

The remote host is using PHPNews, an open source news application.
It utilizes database to store the content.

A vulnerability exists in the remote version of this software
which may permit a possible hacker to inject arbitrary SQL code and
possibly execute arbitrary code, due to improper validation of
user supplied input in the 'mid' parameter of script
'sendtofriend.php'.

Solution : Upgrade to the version 1.2.4 of this software
Network Security Threat Level: High

Networks Security ID: 11748

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security.

Hubs

Discussions

No Discussions have been posted on this vulnerability.