Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PHP-Nuke security vulnerability (bb_smilies.php)


Vulnerability Assessment Details

PHP-Nuke security vulnerability (bb_smilies.php)

Vulnerability Assessment Summary
Determine if a remote host is vulnerable to the bb_smilies.php vulnerability

Detailed Explanation for this Vulnerability Assessment

The remote host seems to be vulnerable to a security problem in PHP-Nuke (bb_smilies.php).
The vulnerability is caused by inadequate processing of queries by PHP-Nuke's bb_smilies.php
which results in returning the content of any file we desire (the file needs to be world-readable).
A similar vulnerability in the same PHP program permits execution of arbitrary code by changing
the password of the administrator of bb_smilies.

Impact:
Every file that the webserver has access to can be read by anyone. It is
also possible to change bb_smilies' administrator password and even execute
arbitrary commands.

Solution:
Change the following lines in both bb_smilies.php and bbcode_ref.php:

if ($userdata[9] != '') $themes = 'themes/$userdata[9]/theme.php'

else $themes = 'themes/$Default_Theme/theme.php'



To:

if ($userdata[9] != '') $themes = 'themes/$userdata[9]/theme.php'

else $themes = 'themes/$Default_Theme/theme.php'

if ( !(strstr(basename($themes),'theme.php')) || !(file_exists($themes)) ){
echo 'Invalid Theme'
exit
}
include ('$themes')



Or upgrade to the latest version (Version 4.4.1 and above).

Network Security Threat Level: Medium

Additional information:
http://www.securiteam.com/securitynews/Serious_security_hole_in_PHP-Nuke__bb_smilies_.html

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2001 SecuriTeam

Cables, Connectors

Dell Vostro 1510 15.4" Notebook - Core 2 Duo CPU @ 1.8ghz, 3GB ram, 150GB HD
$69.99
Dell Vostro 1510 15.4Dell 2900 0YM158 YM158 Motherboard Dual Socket w/ CPU Intel Zeon 5130 2 GHz
$89.99
Dell 2900 0YM158 YM158 Motherboard Dual Socket w/ CPU Intel Zeon 5130 2 GHz pictureIntel Core i3 CPU
$20.0
Intel Core i3 CPU pictureHP Z240 Small Form Factor Workstation - 1 x Processors Supported - 1 x Intel
$958.51
HP Z240 Small Form Factor Workstation - 1 x Processors Supported - 1 x Intel picture


Discussions

No Discussions have been posted on this vulnerability.