Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PHP-Fusion < 6.00.110 Multiple SQL Injection Vulnerabilities


Vulnerability Assessment Details

PHP-Fusion < 6.00.110 Multiple SQL Injection Vulnerabilities

Vulnerability Assessment Summary
Checks for SQL injection in PHP-Fusion's register.php

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote host contains several PHP scripts that are vulnerable to
SQL injection flaws.

Description :

The remote version of this software is vulnerable to multiple SQL
injection attacks due to its failure to properly sanitize certain
parameters. Provided PHP's 'magic_quotes_gpc' setting is disabled,
these flaws permit a possible hacker to manipulate database queries, which
may result in the disclosure or modification of data.

See also :

http://securityfocus.org/archive/1/411909
http://archives.neohapsis.com/archives/secunia/2005-q4/0021.html
http://www.gnucitizen.org/writings/php-fusion-messages.php-sql-injection-vulnerability.xhtml
http://secunia.com/secunia_research/2005-52/advisory

Solution :

Update to at least version 6.00.110 of PHP-Fusion.

Network Security Threat Level:

Low / CVSS Base Score : 3
(AV:R/AC:H/Au:NR/C:P/A:N/I:N/B:C)

Networks Security ID: 14964, 14992, 15005, 15018

Vulnerability Assessment Copyright: (C) 2005 Josh Zlatin-Amishav

Cables, Connectors

One Atari Joystick🕹 Controller Original From The 1980’s Retro
$17.73
One Atari Joystick🕹 Controller Original From The 1980’s Retro pictureRARE collectors item: ATARI AirCars game with manual
$320.0
RARE collectors item: ATARI AirCars game with manual pictureNEW, VBXE for the Atari XE Computers v2.1
$99.99
NEW, VBXE for the Atari XE Computers v2.1 pictureAtari Basic, For Atari Computers
$3.25
Atari Basic, For Atari Computers picture


Discussions

No Discussions have been posted on this vulnerability.