Vulnerability Assessment & Network Security Forums
If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important. If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.
Vulnerability Assessment Details
Checks for multiple vulnerabilities in PHP < 4.4.1 / 5.0.6
Detailed Explanation for this Vulnerability Assessment
The remote web server uses a version of PHP that is affected by
According to its banner, the version of PHP installed on the remote
host is older than 4.4.1 or 5.0.6. Such versions fail to protect the
'$GLOBALS' superglobals variable from being overwritten due to
weaknesses in the file upload handling code as well as the 'extract()'
and 'import_request_variables()' functions. Depending on the nature
of the PHP applications on the affected host, exploitation of this
issue may lead to any number of attacks, including arbitrary code
In addition, these versions may enable a possible hacker to exploit an
integer overflow flaw in certain certain versions of the PCRE library,
to enable PHP's 'register_globals' setting even if explicitly disabled
in the configuration, and to launch cross-site scripting attacks
involving PHP's 'phpinfo()' function.
See also :
Upgrade to PHP version 4.4.1 / 5.0.6 or later.
Network Security Threat Level:
Medium / CVSS Base Score : 6
Networks Security ID: 14620, 15248, 15249, 15250
Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security
|Hynix 8GB 2Rx4 PC3-14900E DDR3 Server Memory Unbuffered HP Microserver Gen8
|Super Micro SuperServer X8DAH+ 2X Xeon 2.13GHZ/4GB/160GB
|HP Proliant MicroServer AMD Athlon II Neo N36L Dual-Core 1.3GHz, 8GB Memory
|HP ProLiant ML10 G9 4U Micro Tower Server - 1 x Intel Pentium G4400 Dual-core
No Discussions have been posted on this vulnerability.