Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> OpenSSH Channel Code Off by 1


Vulnerability Assessment Details

OpenSSH Channel Code Off by 1

Vulnerability Assessment Summary
Checks for the remote OpenSSH version

Detailed Explanation for this Vulnerability Assessment

You are running a version of OpenSSH which is older than 3.1.

Versions prior than 3.1 are vulnerable to an off by one error
that permits local users to gain root access, and it may be
possible for remote users to similarly compromise the daemon
for remote access.

In addition, a vulnerable SSH client may be compromised by
connecting to a malicious SSH daemon that exploits this
vulnerability in the client code, thus compromising the
client system.

Solution : Upgrade to OpenSSH 3.1 or apply the patch for
prior versions. (See: http://www.openssh.org)

Network Security Threat Level: High

Networks Security ID: 4241

Vulnerability Assessment Copyright: This script is Copyright (c) 2002 Thomas Reinke

Cables, Connectors

ADATA Ultimate SU800 M.2 2280 512GB SATA III 3D TLC Internal Solid State Drive
$149.99
ADATA Ultimate SU800 M.2 2280 512GB SATA III 3D TLC Internal Solid State Drive pictureCrucial MX300 1 TB 2.5" Internal Solid State Drive (New and )
$249.99
Crucial MX300 1 TB 2.5PNY CS1311 960GB 2.5” SATA III Internal Solid State Drive(New and )
$269.99
PNY CS1311 960GB 2.5” SATA III Internal Solid State Drive(New and ) pictureFusion-IO 640GB MLC IoDuo PCI-Express Flash Drive SSD Storage Accelerator
$599.0
Fusion-IO 640GB MLC IoDuo PCI-Express Flash Drive SSD Storage Accelerator picture


Discussions

No Discussions have been posted on this vulnerability.