Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> OpenSSH <= 3.3


Vulnerability Assessment Details

OpenSSH <= 3.3

Vulnerability Assessment Summary
Checks for the remote SSH version

Detailed Explanation for this Vulnerability Assessment

You are running a version of OpenSSH which is older than 3.4

There is a flaw in this version that can be exploited remotely to
give a possible hacker a shell on this host.

Note that several distribution patched this hole without changing
the version number of OpenSSH. Since Nessus solely relied on the
banner of the remote SSH server to perform this check, this might
be a false positive.

If you are running a RedHat host, make sure that the command :
rpm -q openssh-server

Returns :
openssh-server-3.1p1-6


Solution : Upgrade to OpenSSH 3.4 or contact your vendor for a patch
Network Security Threat Level: High

Networks Security ID: 5093

Vulnerability Assessment Copyright: This script is Copyright (C) 2002 Renaud Deraison

Cables, Connectors

MOTOROLA MOSCAD NFM XC RTU for Network Fault Management Multi port – F4551A
$450.0
MOTOROLA MOSCAD NFM XC RTU for Network Fault Management Multi port – F4551A pictureNEW Open Box Dell PowerConnect 2824 1u 24-port Gigabit Switch w/Accessories
$199.95
NEW Open Box Dell PowerConnect 2824 1u 24-port Gigabit Switch w/Accessories pictureTP-Link 5-Port Fast Ethernet Desktop Switch (TL-SF1005D)
$13.77
TP-Link 5-Port Fast Ethernet Desktop Switch (TL-SF1005D) pictureCISCO DS-C9124-K9 24 port Multilayer Fabric Switch
$19.99
CISCO DS-C9124-K9 24 port Multilayer Fabric Switch picture


Discussions

No Discussions have been posted on this vulnerability.