Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Netware >> Novell NetWare HTTP POST Perl Code Execution Vulnerability


Vulnerability Assessment Details

Novell NetWare HTTP POST Perl Code Execution Vulnerability

Vulnerability Assessment Summary
Webserver perl handler executes arbitrary POSTs

Detailed Explanation for this Vulnerability Assessment

Novell Netware contains multiple default web server installations.
The Netware Enterprise Web Server (Netscape/IPlanet) has a perl
handler which will run arbitrary code given to in a POST request
version 5.x (through SP4) and 6.x (through SP1) are effected.

Network Security Threat Level: High

Solution : Install 5.x SP5 or 6.0 SP2

Additionally, the enterprise manager web interface may be used to
unmap the /perl handler entirely. If it is not being used, minimizing
this service would be appropriate.

Networks Security ID: 5520, 5521, 5522

Vulnerability Assessment Copyright: This script is Copyright (C) 2002 visigoth

Cables, Connectors

IBM 90Y8914 HDD 300G 10K SAS6 G2 2.5 SED 90Y8913 90Y8917 SERVER HARD DISK DRIVE
$40.58
IBM 90Y8914 HDD 300G 10K SAS6 G2 2.5 SED 90Y8913 90Y8917 SERVER HARD DISK DRIVE pictureLENOVO IBM SYSTEM X 500GB SERVER ST900620SS 7.2K Hard Drive 9RZ264-039
$1.0
LENOVO IBM SYSTEM X 500GB SERVER ST900620SS 7.2K Hard Drive 9RZ264-039  pictureIBM E SERVER XSERIES 73.4GB 10K RPM SAS
$4.24
IBM E SERVER XSERIES 73.4GB 10K RPM SAS pictureIBM Blade Server HS21 8853AC1 with 2x Xeon 5150, 4x 2G DDR2c Qlogic 4Gb Fiber
$74.29
IBM Blade Server HS21 8853AC1 with 2x Xeon 5150, 4x 2G DDR2c Qlogic 4Gb Fiber picture


Discussions

No Discussions have been posted on this vulnerability.