Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Netware >> Netware Web Server Sample Page Source Disclosure


Vulnerability Assessment Details

Netware Web Server Sample Page Source Disclosure

Vulnerability Assessment Summary
Checks for Netware Web Server Source Disclosure

Detailed Explanation for this Vulnerability Assessment

On a Netware Web Server, viewcode.jse permits the source code of web pages to
be viewed. As an argument, a URL is passed to sewse.nlm. The URL can be
altered and will permit files outside of the web root to be viewed.
As a result, sensitive information could be obtained from the Netware server,
such as the RCONSOLE password located in AUTOEXEC.NCF.

Example: http://target//lcgi/sewse.nlm?sys:/novonyx/suitespot/docs/sewse/viewcode.jse+httplist+httplist/../../../../../system/autoexec.ncf


Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2002 David Kyger

Cables, Connectors

Dell Enterprise Plus HGST 1.92TB SAS 12G SSD Solid State Drive MLC 99%
$475.0
Dell Enterprise Plus HGST 1.92TB SAS 12G SSD Solid State Drive MLC 99%  pictureSQL Server 2019 Standard Product Key License MS 24 CPU Cores
$44.99
SQL Server 2019 Standard Product Key License MS 24 CPU Cores pictureSQL Server 2017 Standard Product Key License MS 24 CPU Cores
$44.99
SQL Server 2017 Standard Product Key License MS 24 CPU Cores  picture100% Genuine: Microsoft Windows 2000 Server 10 CAL Retail Box (MPN: C11-00018)
$95.0
100% Genuine: Microsoft Windows 2000 Server 10 CAL Retail Box (MPN: C11-00018) picture


Discussions

No Discussions have been posted on this vulnerability.