Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Netref Cat_for_gen.PHP Remote PHP Script Injection Vulnerability


Vulnerability Assessment Details

Netref Cat_for_gen.PHP Remote PHP Script Injection Vulnerability

Vulnerability Assessment Summary
Netref Cat_for_gen.PHP Remote PHP Script Injection Vulnerability

Detailed Explanation for this Vulnerability Assessment

The remote host is running the Netref directory script, written in
PHP.

There is a vulnerability in the installed version of Netref that
enables a remote attacker to pass arbitrary PHP script code through
the 'ad', 'ad_direct', and 'm_for_racine' parameters of the
'cat_for_gen.php' script. This code will be executed on the remote
host under the rights of the web server userid.

Solution : Upgrade to Netref 4.3 or later.
Network Security Threat Level: High

Networks Security ID: 13275

Vulnerability Assessment Copyright: Copyright (C) 2005 Josh Zlatin-Amishav

Cables, Connectors

Dell 300GB 2.5" 10K 12Gb SAS Hard Drive RDKH0 M620 M420 M520 M820 Blade Server
$59.59
Dell 300GB 2.5Cisco UCS B200 M3 Blade Server Dual E5-2695 V2 2.4GHz 12C 192GB DDR3 VIC 1240
$955.0
Cisco UCS B200 M3 Blade Server Dual E5-2695 V2 2.4GHz 12C 192GB DDR3 VIC 1240 pictureDELL POWEREDGE M610 SERVER BLADE 2X X5667 3.06GHz CPU 24GB RAM NO HD NO CADDY
$35.0
DELL POWEREDGE M610 SERVER BLADE 2X X5667 3.06GHz CPU 24GB RAM NO HD NO CADDY pictureDELL POWEREDGE M610 SERVER BLADE 2X X5667 3.06GHz CPU 24GB RAM NO HD NO CADDY
$40.0
DELL POWEREDGE M610 SERVER BLADE 2X X5667 3.06GHz CPU 24GB RAM NO HD NO CADDY picture


Discussions

No Discussions have been posted on this vulnerability.