Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> MyDMS SQL Injection and Directory Traversal


Vulnerability Assessment Details

MyDMS SQL Injection and Directory Traversal

Vulnerability Assessment Summary
SQL injection against the remote MyDMS installation

Detailed Explanation for this Vulnerability Assessment

The remote host is running MyDMS, an open source document management
system based on MySQL and PHP.

The remote version of this software is vulnerable to a SQL injection
bug which may permit any guest user to execute arbitrary SQL commands
against the remote database. There is also a directory traversal issue
which may permit logged users to read arbitrary files on the remote
host with the rights of the HTTP daemon.

Solution : Upgrade to MyDMS 1.4.3
Network Security Threat Level: High

Networks Security ID: 10996

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Intel Core i7-7700K Processor with EVGA Stinger Z170 ITX Motherboard Combo
$165.0
Intel Core i7-7700K Processor with EVGA Stinger Z170 ITX Motherboard Combo pictureIntel Core I7-4770 3.40GHz Quad Core SR149 Processor
$110.0
Intel Core  I7-4770 3.40GHz Quad Core  SR149 Processor pictureAMD FX-8350 4000MHz 8-Core (FD8350FRHKBOX) Processor - includes heatsink & fan
$49.99
AMD FX-8350 4000MHz 8-Core (FD8350FRHKBOX) Processor - includes heatsink & fan pictureMicrosoft Surface Pro 3 Intel Core i7-4650U CPU 1.70GHz 256GB HD 8GB RAM Win 10
$175.0
Microsoft Surface Pro 3 Intel Core i7-4650U CPU 1.70GHz 256GB HD 8GB RAM Win 10 picture


Discussions

No Discussions have been posted on this vulnerability.