Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> MyBB < 1.01 SQL Injection Vulnerabilities


Vulnerability Assessment Details

MyBB < 1.01 SQL Injection Vulnerabilities

Vulnerability Assessment Summary
Checks for SQL injection vulnerabilities in MyBB < 1.01

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server has a PHP application that is affected by
multiple SQL injection vulnerabilities.

Description :

The installed version of MyBB fails to validate user input to the
'mybbadmin' cookie in the 'admin/global.php' script as well as the
extension of a file upload before using them in database queries. An
attacker may be able to leverage these issues to disclose sensitive
information, modify data, or launch attacks against the underlying
database.

Note that exploitation of the second issue may require authentication
while the first does not.

See also :

http://www.securityfocus.com/archive/1/420573
http://community.mybboard.net/showthread.php?tid=5633

Solution :

Upgrade to MyBB version 1.01 or later.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 16082, 16097

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

Juniper Networks WLC2800
$990.0
Juniper Networks WLC2800 pictureNew Juniper Networks M7i Chassis Base + more Fully Loaded
$1499.99
New Juniper Networks M7i Chassis Base + more  Fully Loaded pictureAddOn Juniper Compatible SFP+ Transceiver - SFP+ transceiver QFX-SFP-10GE-SR-AO
$294.99
AddOn Juniper Compatible SFP+ Transceiver - SFP+ transceiver  QFX-SFP-10GE-SR-AO pictureAddOn Juniper Compatible QSFP+ Transceiver - QSFP+ transceiv QFX-QSFP-40G-SR4-AO
$409.99
AddOn Juniper Compatible QSFP+ Transceiver - QSFP+ transceiv QFX-QSFP-40G-SR4-AO picture


Discussions

No Discussions have been posted on this vulnerability.