Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Multiple vulnerabilities in phpBB 2.0.14 and older


Vulnerability Assessment Details

Multiple vulnerabilities in phpBB 2.0.14 and older

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in phpBB 2.0.14 and older

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

According to its banner, the remote host is running a version of phpBB
that suffers from multiple flaws:

- A BBCode Input Validation Vulnerability
The application fails to properly filter for the BBCode
URL in the 'includes/bbcode.php' script. With a specially-
crafted URL, a possible hacker cause arbitrary script code to be
executed in a user's browser, possibly even to modify
registry entries without the user's knowledge.

- Cross-Site Scripting Vulnerabilities
The application does not properly sanitize user-supplied input
to the 'forumname' and 'forumdesc' parameters of the
'admin/admin_forums.php' script. By enticing an phpBB
administrator to visit a a specially-crafted link, a possible hacker
can potentially steal the admin's session cookie or perform
other attacks.

- Improper Filtering of HTML Code
The application does not completely filter user-supplied input
to the 'u' parameter of the 'profile.php' script or the
'highlight' parameter of the 'viewtopic.php' script.

See also :

http://archives.neohapsis.com/archives/bugtraq/2005-04/0383.html
http://castlecops.com/t123194-.html
http://www.phpbb.com/phpBB/viewtopic.php?f=14&t=288194

Solution :

Upgrade to phpBB version 2.0.15 or later.

Network Security Threat Level:

Low / CVSS Base Score : 3
(AV:R/AC:H/Au:NR/C:N/A:N/I:C/B:N)

Networks Security ID: 13344, 13345, 13545

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Juniper SA 4500 SSL/VPN 600 CL Users & ICE ** Warranty 12 months ** SA4500
$2779.29
Juniper SA 4500 SSL/VPN 600 CL Users & ICE    ** Warranty 12 months ** SA4500 pictureJuniper SA 4500 SSL/VPN 600 Users ** Warranty 12 months ** SA4500
$2969.66
Juniper SA 4500 SSL/VPN 600 Users   ** Warranty 12 months ** SA4500 pictureQFX-SFP-1GE-SX for Juniper, Gigabit SFP Module, 1000Base-SX SFP Transceiver
$16.99
QFX-SFP-1GE-SX for Juniper, Gigabit SFP Module, 1000Base-SX SFP Transceiver pictureEX-SFP-10GE-DAC-5M Juniper Compatible 10G SFP+ Passive DAC Twinax Cable
$30.0
EX-SFP-10GE-DAC-5M Juniper Compatible 10G SFP+ Passive DAC Twinax Cable picture


Discussions

No Discussions have been posted on this vulnerability.