Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Multiple Vulnerabilities in phpCOIN 1.2.1b and older


Vulnerability Assessment Details

Multiple Vulnerabilities in phpCOIN 1.2.1b and older

Vulnerability Assessment Summary
Detects multiple vulnerabilities in phpCOIN 1.2.1b and older

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application affected by several
flaws.

Description :

The remote host is running phpCOIN version 1.2.1b or older. These
versions suffer from several vulnerabilities, among them :

- A Local File Include Vulnerability
A possible hacker can execute arbitrary code in the context of the
web server user by passing the name of a script or file through
the 'page' parameter of the 'auxpage.php' script.

- Multiple SQL injection vulnerabilities.
By calling the 'faq' module with a specially crafted
'faq_id' parameter or the 'pages' or 'site' modules with a
specially crafted 'id' parameter, a remote attacker may be
able to manipulate SQL queries used by the program, thereby
revealing sensitive information or even corrupting the
database.

- Multiple cross-site scripting vulnerabilities.
A remote attacker may be able to inject arbitrary code
into the 'helpdesk' and 'mail' modules as well as the
'login.php' script by appending it to a valid request.
Successful exploitation may permit a possible hacker to steal
authentication cookies or misrepresent site content.

See also :

http://www.gulftech.org/?node=research&article_id=00065-03292005
http://archives.neohapsis.com/archives/bugtraq/2005-03/0508.html
http://forums.phpcoin.com//index.php?showtopic=4210

Solution :

Apply the 2005-03-14 fix file or later for phpCOIN v1.2.2.

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:H/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 12686, 12917

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Dell R730 Dual E5-2660 v3 10C 2.6GHz 512GB 4x 480GB SSD H730 iDRAC 2.5in Rails
$10087.0
Dell R730 Dual E5-2660 v3 10C 2.6GHz 512GB 4x 480GB SSD H730 iDRAC 2.5in Rails pictureHP Renew DL360 G9 Single E5-2620 v3 6C 2.4GHz 128GB 8x 450GB SAS P440ar Rails
$4492.0
HP Renew DL360 G9 Single E5-2620 v3 6C 2.4GHz 128GB 8x 450GB SAS P440ar Rails pictureDell R720xd OEM Dual E5-2660 8C 2.2GHz 384GB 12x 1TB SAS 12 Bay 3.5in Rails RPS
$3606.0
Dell R720xd OEM Dual E5-2660 8C 2.2GHz 384GB 12x 1TB SAS 12 Bay 3.5in Rails RPS pictureDell R710 Dual L5520 QC 2.26GHz 192GB 2x 300GB 6G, 6x 600GB 6G H700 iDRAC Rails
$1676.0
Dell R710 Dual L5520 QC 2.26GHz 192GB 2x 300GB 6G, 6x 600GB 6G H700 iDRAC Rails picture


Discussions

No Discussions have been posted on this vulnerability.