Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Multiple Vulnerabilities in PostNuke <= 0.760 RC4a


Vulnerability Assessment Details

Multiple Vulnerabilities in PostNuke <= 0.760 RC4a

Vulnerability Assessment Summary
Detects multiple vulnerabilities in PostNuke <= 0.760 RC4a

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is prone to several
attacks.

Description :

The remote host is running PostNuke version 0.760 RC4a or older.
These versions suffer from several vulnerabilities, among them :

- Multiple Remote Code Injection Vulnerabilities
A possible hacker can read arbitrary files on the remote and
possibly inject arbitrary PHP code remotely.

- SQL Injection Vulnerabilities
Weaknesses in the 'Xanthia' and 'Messages' modules permit
attackers to affect database queries, possibly resulting
in the disclosure of sensitive information such as user
passwords and even execution of arbitrary PHP code on
the remote host.

- Multiple Cross-Site Scripting Vulnerabilities
A possible hacker can inject arbitrary script code into the
browser of users leading to disclosure of session
cookies, redirection to other sites, etc.

- Multiple Path Disclosure Vulnerabilities
A possible hacker can discover details about the underlying
installation directory structure by calling various
include scripts directly.

See also :

http://archives.neohapsis.com/archives/bugtraq/2005-05/0197.html
http://archives.neohapsis.com/archives/bugtraq/2005-05/0254.html
http://archives.neohapsis.com/archives/bugtraq/2005-05/0255.html
http://archives.neohapsis.com/archives/bugtraq/2005-05/0256.html
http://community.postnuke.com/Article2691.htm

Solution :

Apply the security fix package referenced in the article above to
upgrade to PostNuke version 0.750.0b.

Network Security Threat Level:

High / CVSS Base Score : 7
(AV:R/AC:L/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 13706, 13789

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

DELL POWEREDGE M610 BLADE TWO X5675 3.06GHZ 48GB 2 X 1.2TB 10K SAS SAS 6/IR
$1219.0
DELL POWEREDGE M610 BLADE TWO X5675 3.06GHZ 48GB 2 X 1.2TB 10K SAS SAS 6/IR pictureDELL POWEREDGE M610 BLADE TWO E5506 2.13GHZ 24GB 2 X 1TB SATA SAS 6/IR
$709.0
DELL POWEREDGE M610 BLADE TWO E5506 2.13GHZ 24GB 2 X 1TB SATA SAS 6/IR pictureDELL POWEREDGE M610 BLADE TWO E5649 2.53GHZ 96GB 2 X 300GB 10K SAS SAS 6/IR
$1209.0
DELL POWEREDGE M610 BLADE TWO E5649 2.53GHZ 96GB 2 X 300GB 10K SAS SAS 6/IR pictureDELL POWEREDGE M610 BLADE TWO E5520 2.26GHZ 192GB 2 X 1.6TB SSD SAS 6/IR
$3109.0
DELL POWEREDGE M610 BLADE TWO E5520 2.26GHZ 192GB 2 X 1.6TB SSD SAS 6/IR picture


Discussions

No Discussions have been posted on this vulnerability.