Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Moodle < 1.6.2 Multiple Vulnerabilities


Vulnerability Assessment Details

Moodle < 1.6.2 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks if Moodle's jumpto.php requires a sesskey

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that suffers from
multiple vulnerabilities.

Description :

The installed version of Moodle fails to sanitize user-supplied input
to a number of parameters and scripts. A possible hacker may be able to
leverage these issues to launch SQL injection and cross-site scripting
attacks against the affected application.

See also :

http://www.securityfocus.com/archive/1/446227/30/0/threaded
http://docs.moodle.org/en/Release_Notes#Moodle_1.6.2

Solution :

Upgrade to Moodle version 1.6.2 or later.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 19995, 20085

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Lot of 5x Atari Vintage Computers Boards 1979 -1980s 810 Side OS More
$35.0
Lot of 5x Atari Vintage Computers Boards 1979 -1980s 810 Side OS More picture ATARI 800xe - chassis
$27.9
 ATARI 800xe - chassis  picture ATARI 800xe motherboard - not works
$39.9
 ATARI 800xe motherboard  - not works  pictureAtari 65xe
$139.0
Atari 65xe picture


Discussions

No Discussions have been posted on this vulnerability.