Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> MiniShare webserver buffer overflow


Vulnerability Assessment Details

MiniShare webserver buffer overflow

Vulnerability Assessment Summary
MiniShare webserver buffer overflows

Detailed Explanation for this Vulnerability Assessment

MiniShare 1.4.1 and prior versions are affected by a buffer overflow flaw.
A remote attacker could execute arbitrary commands by sending a specially
crafted file name in a the GET request.

Version 1.3.4 and below do not seem to be vulnerable.

Solution: Upgrade to MiniShare 1.4.2 or higher.
Network Security Threat Level: High

Networks Security ID: 11620

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 SensePost

Cables, Connectors

Dell 1TB 2.5'' SAS SED 6G 7.2K Server Hard Drive 0XKGH0 XKGH0 Self-Encrypting
$194.06
Dell 1TB 2.5'' SAS SED 6G 7.2K Server Hard Drive 0XKGH0 XKGH0 Self-Encrypting pictureApple iMac 27" Desktop retina 5k display intelcorei5 8GB memory 1TB hard drive
$1599.0
Apple iMac 27128GB SSD Macbook Air 11" 13" A1465 A1466 2013 2014 2015 macOS Sierra 10.12.4
$159.99
128GB SSD Macbook Air 11LaCie d2 Quadra v3 Hard Disk 2 TB USB 3.0 External Hardrive
$100.0
LaCie d2 Quadra v3 Hard Disk 2 TB USB 3.0  External Hardrive picture


Discussions

No Discussions have been posted on this vulnerability.