Vulnerability Assessment & Network Security Forums

If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.

Home >> Browse Vulnerability Assessment Database >> CGI abuses >> MediaWiki Multiple Remote Vulnerabilities (2)

Vulnerability Assessment Details

MediaWiki Multiple Remote Vulnerabilities (2)

Vulnerability Assessment Summary
Attempts to execute phpinfo() remotely

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a set of PHP scripts that permit an
attacker to execute arbitrary commands the remote host.

Description :

The remote host appears to be running a version of MediaWiki 1.5 older
than version 1.5.3. Due to improper sanitation of user-supplied
input, the installed version of MediaWiki permits an unauthenticated
remote attacker to execute arbitrary PHP and shell commands on the
remote host subject to the rights of the web server user id.

See also :


Upgrade to MediaWiki 1.5.3 or later.

Network Security Threat Level:

High / CVSS Base Score : 7.0

Networks Security ID: 15703

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2007 Tenable Network Security

Cables, Connectors


No Discussions have been posted on this vulnerability.