Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> MediaWiki < 1.3.17 / 1.4.11 / 1.5.0 Multiple Vulnerabilities


Vulnerability Assessment Details

MediaWiki < 1.3.17 / 1.4.11 / 1.5.0 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in MediaWiki < 1.3.17 / 1.4.11 / 1.5.0

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

According to its version number, the version of Mediawiki installed on
the remote host is vulnerable to data corruption bug involving the
submission handling routine when faced with malformed URLs. Under
certain circumstances, this may corrupt the previous revision in the
database. A spam bot known to be active in the wild reportedly can
trigger this issue.

In addition, the application suffers from a cross-site scripting
vulnerability due to its failure to sanitize user-input for HTML
inline style attributes.

See also :

http://sourceforge.net/forum/forum.php?forum_id=501174

Solution :

Upgrade to MediaWiki 1.3.17 or later if using 1.3.x legacy series
to
1.4.11 or later if using 1.4.x
otherwise to 1.5.0 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 4
(AV:R/AC:L/Au:NR/C:N/A:N/I:P/B:I)

Networks Security ID: 15024, 15041

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2007 Tenable Network Security

Cables, Connectors

Dell PowerEdge R630 Server 2x 2.60Ghz E5-2660v3 10C 512GB High-End
$2987.33
Dell PowerEdge R630 Server 2x 2.60Ghz E5-2660v3 10C 512GB High-End pictureDell PowerEdge R720xd Server 2x 2.20Ghz E5-2660v2 10C 256GB Mid-Level
$1112.97
Dell PowerEdge R720xd Server 2x 2.20Ghz E5-2660v2 10C 256GB Mid-Level pictureDell PowerEdge R630 24B Server 2x 3.00Ghz E5-2623v3 QC 128GB Enterprise
$1369.64
Dell PowerEdge R630 24B Server 2x 3.00Ghz E5-2623v3 QC 128GB Enterprise pictureDell PowerEdge R620 Server 2x 3.30Ghz E5-2667v2 8C 128GB 10x 480GB SSD Premium
$1648.42
Dell PowerEdge R620 Server 2x 3.30Ghz E5-2667v2 8C 128GB 10x 480GB SSD Premium picture


Discussions

No Discussions have been posted on this vulnerability.