Vulnerability Assessment & Network Security Forums

If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.

Home >> Browse Vulnerability Assessment Database >> CGI abuses >> MediaWiki < 1.3.17 / 1.4.11 / 1.5.0 Multiple Vulnerabilities

Vulnerability Assessment Details

MediaWiki < 1.3.17 / 1.4.11 / 1.5.0 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in MediaWiki < 1.3.17 / 1.4.11 / 1.5.0

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

According to its version number, the version of Mediawiki installed on
the remote host is vulnerable to data corruption bug involving the
submission handling routine when faced with malformed URLs. Under
certain circumstances, this may corrupt the previous revision in the
database. A spam bot known to be active in the wild reportedly can
trigger this issue.

In addition, the application suffers from a cross-site scripting
vulnerability due to its failure to sanitize user-input for HTML
inline style attributes.

See also :

Solution :

Upgrade to MediaWiki 1.3.17 or later if using 1.3.x legacy series
1.4.11 or later if using 1.4.x
otherwise to 1.5.0 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 4

Networks Security ID: 15024, 15041

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2007 Tenable Network Security

Cables, Connectors

Mid-2013 MacBook Air 13" A1466 Lower Assembly, Core i5 1.3GHz 4GB RAM For PARTS
Mid-2013 MacBook Air 13Microsoft 12.3" Surface Pro 7 i5-1035G4 256GB SSD 8GB RAM Black
Microsoft 12.3MacBook Air 13.3" Early 2014 A1466 MF068LL i7 @ 1.70 GHz No SSD/HDD 8GB RAM .MH
MacBook Air 13.3


No Discussions have been posted on this vulnerability.