Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> MailEnable IMAP EXAMINE Command Buffer Overflow


Vulnerability Assessment Details

MailEnable IMAP EXAMINE Command Buffer Overflow

Vulnerability Assessment Summary
Checks for EXAMINE command buffer overflow in MailEnable's IMAP service

Detailed Explanation for this Vulnerability Assessment

Summary :

It is possible to execute code on the remote IMAP server.

Description :

The remote host is running a version of MailEnable's IMAP service that
is prone to a buffer overflow vulnerability triggered when processing
a EXAMINE command with a long mailbox name. Once authenticated, an
attacker can exploit this flaw to execute arbitrary code subject to
the rights of the affected application. There are also reportedly
similar issues with other IMAP commands.

See also :

http://lists.grok.org.uk/pipermail/full-disclosure/2005-December/040388.html

Solution :

Install Hotfix ME-10010 for MailEnable Professional 1.71 and earlier or
MailEnable Enterprise Edition 1.1 and earlier.

Network Security Threat Level:

Low / CVSS Base Score : 3.3
(AV:R/AC:L/Au:NR/C:N/I:N/A:C/B:N)

Networks Security ID: 15985

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

HP ProLiant DL360p Gen8 2x 3.0GHz E5-2690v2 10Core Xeon 96Gb Ram 2x146Gb 15K SAS
$1369.0
HP ProLiant DL360p Gen8 2x 3.0GHz E5-2690v2 10Core Xeon 96Gb Ram 2x146Gb 15K SAS pictureDELL R620 8 BAY SERVER E5-2667 2.90GHZ 16GB 6 X 600GB 15K SAS H310
$2469.0
DELL R620 8 BAY SERVER E5-2667 2.90GHZ 16GB 6 X 600GB 15K SAS H310 pictureHPE HP DL380 G9 Gen9 SERVER TWO E5-2697AV4 2.6GHZ 144GB 8 X 480GB SSD
$10589.0
HPE HP DL380 G9 Gen9 SERVER TWO E5-2697AV4 2.6GHZ 144GB 8 X 480GB SSD picture


Discussions

No Discussions have been posted on this vulnerability.