Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> MacOS X Finder reveals contents of Apache Web directories


Vulnerability Assessment Details

MacOS X Finder reveals contents of Apache Web directories

Vulnerability Assessment Summary
Checks for .DS_Store

Detailed Explanation for this Vulnerability Assessment

MacOS X creates a hidden file, '.DS_Store' in each directory that has
been viewed with the 'Finder'. This file contains a list of the
contents of the directory, giving a possible hacker information on the
structure and contents of your website.

Solution: Use a directive in httpd.conf to forbid
retrieval of this file:


Order permit, deny
Deny from all


and restart Apache.

Network Security Threat Level: Medium
(possibly High depending on the sensitivity of your web content)

References:

www.macintouch.com/mosxreaderreports46.html


Networks Security ID: 3316, 3325

Vulnerability Assessment Copyright: This script is Copyright (C) 2001 Matt Moore

Cables, Connectors

Cisco ASA5585-S20-K9 8xGE 2xGE SFP 3DES/AES ASA5585 Firewall SSP-20 2x AC PSU HS
$2595.0
Cisco ASA5585-S20-K9 8xGE 2xGE SFP 3DES/AES ASA5585 Firewall SSP-20 2x AC PSU HS pictureCisco Adaptive Firewall Security Appliance ASA 5515-X AS IS Parts or Repair
$150.0
Cisco Adaptive Firewall Security Appliance  ASA 5515-X AS IS Parts or Repair pictureFreedom 9 FreeGaurd 100 F002500 Firewall Missing 1 leg
$20.0
Freedom 9 FreeGaurd 100 F002500 Firewall Missing 1 leg pictureSonicWall TZ600 High Availability - security appliance
$800.0
SonicWall TZ600 High Availability - security appliance picture


Discussions

No Discussions have been posted on this vulnerability.