Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> JBoss Malformed HTTP Request Remote Information Disclosure


Vulnerability Assessment Details

JBoss Malformed HTTP Request Remote Information Disclosure

Vulnerability Assessment Summary
Attempts to read security policy of a remote JBoss server

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server is affected by an information disclosure flaw.

Description :

The remote JBoss server is vulnerable to an information disclosure
flaw which may permit a possible hacker to retrieve the physical path of the
server installation, its security policy, or to guess its exact
version number. A possible hacker may use this flaw to gain more
information about the remote configuration.

See also :

http://marc.theaimsgroup.com/?l=bugtraq&m=111911095424496&w=2
http://www.securityfocus.com/advisories/10104

Solution :

Upgrade to JBoss 3.2.8 or 4.0.3. Or edit JBoss' 'jboss-service.xml'
configuration file, set 'DownloadServerClasses' to 'false', and
restart the server.

Network Security Threat Level:

Low / CVSS Base Score : 2.3
(AV:R/AC:L/Au:NR/C:P/I:N/A:N/B:N)

Networks Security ID: 13985, 16571

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

INTELLINET 560771 65-Watt, 16-Port Fast Ethernet PoE+ Switch
$216.87
INTELLINET 560771 65-Watt, 16-Port Fast Ethernet PoE+ Switch pictureINTELLINET 530378 5-Port Gigabit Desktop Ethernet Switch
$42.31
INTELLINET 530378 5-Port Gigabit Desktop Ethernet Switch pictureINTELLINET 560566 1-Port Gigabit High-Power PoE+ Injector
$58.68
INTELLINET 560566 1-Port Gigabit High-Power PoE+ Injector pictureINTELLINET 560641 8-Port PoE+ Desktop Gigabit Switch
$191.23
INTELLINET 560641 8-Port PoE+ Desktop Gigabit Switch picture


Discussions

No Discussions have been posted on this vulnerability.