Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> JBoss JMX Console DeploymentFileRepository Directory Traversal Vulnerability


Vulnerability Assessment Details

JBoss JMX Console DeploymentFileRepository Directory Traversal Vulnerability

Vulnerability Assessment Summary
Tries to change the JMX Console DeploymentFileRepository's BaseDir

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a Java service that is affected by a
directory traversal flaw.

Description :

The remote web server appears to be a version of JBoss that fails to
sanitize user-supplied input to the BaseDir parameter used by the
'DeploymentFileRepository' service of JMX Console before using it to
store or delete files. An unauthenticated attacker may be able to
exploit this to alter files on the remote host subject to the
rights of the JBoss user.

See also :

http://www.securityfocus.com/archive/1/archive/1/452830/100/0/threaded
http://jira.jboss.com/jira/browse/JBAS-3861
http://wiki.jboss.org/wiki/Wiki.jsp?page=SecureTheJmxConsole

Solution :

Secure access to the JMX Console as described in the Wiki article
referenced above.

Network Security Threat Level:

High / CVSS Base Score : 7
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 21219

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

HP ML350p G8 Tower 12-Core Server 2x E5-2667 2.9GHz 384GB-16 8x 1.8TB SAS RPS
$6211.92
HP ML350p G8 Tower 12-Core Server 2x E5-2667 2.9GHz 384GB-16 8x 1.8TB SAS RPS pictureHP DL360 G9 28-Core Server 2x E5-2695 v3 2.3GHz 64GB-16 8x 1.8TB SAS P440ar RPS
$8318.31
HP DL360 G9 28-Core Server 2x E5-2695 v3 2.3GHz 64GB-16 8x 1.8TB SAS P440ar RPS pictureHP DL360p G8 20-Core Server 2x E5-2650L v2 1.7GHz 128GB-8 4x 1TB LFF 4 Bay RPS
$1282.5
HP DL360p G8 20-Core Server 2x E5-2650L v2 1.7GHz 128GB-8 4x 1TB LFF 4 Bay RPS pictureDell R630 36-Core Server 2x E5-2699 v3 2.3GHz 384GB-16 8x 1.2TB SAS H730 RPS
$8607.17
Dell R630 36-Core Server 2x E5-2699 v3 2.3GHz 384GB-16 8x 1.2TB SAS H730 RPS picture


Discussions

No Discussions have been posted on this vulnerability.