Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> IMAP4buffer overflow in the BODY command


Vulnerability Assessment Details

IMAP4buffer overflow in the BODY command

Vulnerability Assessment Summary
checks for a buffer overflow in imapd

Detailed Explanation for this Vulnerability Assessment

Summary :

It is possible to execute arbitrary code on the remote host, through the
IMAP server.

Description :

The remote version of UW-IMAP is vulnerable to a buffer overflow condition
which may permit an authenticated attacker to execute arbitrary code on the
remote host with the rights of the IMAP server.


Solution :

Upgrade to imap-2001a

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:L/Au:R/C:C/A:C/I:C/B:N)

Networks Security ID: 4713

Vulnerability Assessment Copyright: This script is Copyright (C) Tenable Network Security

Cables, Connectors

Cisco UC520 UC520-16U-2BRI-K9 16-User Voice VoIP Unified Communications Router
$319.31
Cisco UC520 UC520-16U-2BRI-K9 16-User Voice VoIP Unified Communications Router  pictureCisco ATA187 Analog / VoIP Digital Telephone Adapter Unit ATA187V01 / 74-7022-01
$268.9
Cisco ATA187 Analog / VoIP Digital Telephone Adapter Unit ATA187V01 / 74-7022-01 pictureShoreTel 565 IP VoIP Black Colour Display Office Telephone With Stand & Handset
$210.08
ShoreTel 565 IP VoIP Black Colour Display Office Telephone With Stand & Handset pictureShoreTel IP 230G VoIP Black Office Speakerphone Telephone With Stand & Handset
$109.24
ShoreTel IP 230G VoIP Black Office Speakerphone Telephone With Stand & Handset picture


Discussions

No Discussions have been posted on this vulnerability.