Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Windows >> Google Desktop Cross-Site Scripting Flaw


Vulnerability Assessment Details

Google Desktop Cross-Site Scripting Flaw

Vulnerability Assessment Summary
Checks version of Google Desktop

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote host has an application installed that is vulnerable to a
local cross-site scripting vulnerability.

Description :

The version of Google Desktop installed on the remote host is
vulnerable to a cross-site scripting flaw because it fails to properly
encode the output for the 'under' keyword. This issue cannot be
directly exploited remotely, however when used in conjunction with a
known Google.com cross-site scripting vulnerability to extract the
unique signature associated with Google Desktop software, and might
permit a possible hacker to query a victim's system for sensitive
information.

See also :

http://download.watchfire.com/googledesktopdemo/index.htm
http://download.watchfire.com/whitepapers/Overtaking-Google-Desktop.pdf
http://desktop.google.com/support/bin/answer.py?answer=14280

Solution:

Google Desktop automatically updates itself when a new version of the
software is available. However in some cases it may not be able to
update itself due to network connectivity issues. Please ensure that
Google Desktop version 5.0.0701.30540 or later is installed.

Network Security Threat Level:

High / CVSS Base Score : 8.0
(AV:R/AC:H/Au:NR/C:C/I:C/A:C/B:N)

Networks Security ID: 22650

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

HPE PROLIANT DL380 G9 Gen9 SERVER TWO E5-2660V4 2GHZ 768GB 2 X 240GB SSD
$17189.0
HPE PROLIANT DL380 G9 Gen9 SERVER TWO E5-2660V4 2GHZ 768GB 2 X 240GB SSD pictureHPE PROLIANT DL380 G9 Gen9 SERVER TWO E5-2609V3 1.9GHZ 256GB 3 X 1.6TB SSD
$8469.0
HPE PROLIANT DL380 G9 Gen9 SERVER TWO E5-2609V3 1.9GHZ 256GB 3 X 1.6TB SSD picture32GB 8x4GB PC3-8500R ECC Server RAM IBM X3850 X5 w/ Expansion Module 46M0001
$89.95
32GB 8x4GB PC3-8500R ECC Server RAM IBM X3850 X5 w/ Expansion Module 46M0001 pictureDELL POWEREDGE R730 16 BAY TWO E5-2643V3 3.4GHZ 64GB 2 X 600GB SSD H730
$6389.0
DELL POWEREDGE R730 16 BAY TWO E5-2643V3 3.4GHZ 64GB 2 X 600GB SSD H730 picture


Discussions

No Discussions have been posted on this vulnerability.