Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200702-11] MPlayer: Buffer overflow


Vulnerability Assessment Details

[GLSA-200702-11] MPlayer: Buffer overflow

Vulnerability Assessment Summary
MPlayer: Buffer overflow

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200702-11
(MPlayer: Buffer overflow)


When checking for matching asm rules in the asmrp.c code, the results
are stored in a fixed-size array without boundary checks which may
permit a buffer overflow.

Impact

A possible hacker can entice a user to connect to a manipulated RTSP server
resulting in a Denial of Service and possibly execution of arbitrary
code.

Workaround

There is no known workaround at this time.

References:
http://www.mplayerhq.hu/design7/news.html#vuln14
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-6172


Solution:
All MPlayer users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/mplayer-1.0_rc1-r2"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2007 Michel Arboi

Cables, Connectors

IBM X SERIES X3650 M2 SERVER SYSTEM BOARD FRU 43V7072
$84.99
IBM X SERIES X3650 M2 SERVER SYSTEM BOARD FRU 43V7072 picture39M4533 500GB 7200rpm Hard Drive pulled from X3650 Server FRU IBM System 39M4530
$120.0
39M4533 500GB 7200rpm Hard Drive pulled from X3650 Server FRU IBM System 39M4530 pictureIBM #FRU:09N6043 Server side panel LATCH-black
$3.99
IBM #FRU:09N6043 Server side panel LATCH-black pictureIBM ServeRAID-3H SCSI Controller Card Server 76H3587
$23.99
IBM ServeRAID-3H SCSI Controller Card Server 76H3587  picture


Discussions

No Discussions have been posted on this vulnerability.