Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200702-02] ProFTPD: Local privilege escalation


Vulnerability Assessment Details

[GLSA-200702-02] ProFTPD: Local privilege escalation

Vulnerability Assessment Summary
ProFTPD: Local privilege escalation

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200702-02
(ProFTPD: Local privilege escalation)


A flaw exists in the mod_ctrls module of ProFTPD, normally used to
permit FTP server administrators to configure the daemon at runtime.

Impact

An FTP server administrator permitted to interact with mod_ctrls could
potentially compromise the ProFTPD process and execute arbitrary code
with the rights of the FTP Daemon, which is normally the root user.

Workaround

Disable mod_ctrls, or ensure only trusted users can access this
feature.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-6563


Solution:
All ProFTPD users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-ftp/proftpd-1.3.1_rc1"


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2007 Michel Arboi

Cables, Connectors

Lot of 6 Cisco IP Phone SPA514G 4 Line VOIP Phones
$239.99
 Lot of 6 Cisco IP Phone SPA514G 4 Line VOIP Phones pictureCisco 73-7945 4-port Voice/Fax Interface Card VIC2-4FX0 For 2800/3800
$9.9
Cisco 73-7945 4-port Voice/Fax Interface Card VIC2-4FX0 For 2800/3800 pictureCISCO 74-7119-01 PCI-E 2 X8 LSI SAS RAID CONTROLLER CARD
$45.0
CISCO 74-7119-01 PCI-E 2 X8 LSI SAS RAID CONTROLLER CARD picture


Discussions

No Discussions have been posted on this vulnerability.