Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200611-20] GNU gv: Stack overflow


Vulnerability Assessment Details

[GLSA-200611-20] GNU gv: Stack overflow

Vulnerability Assessment Summary
GNU gv: Stack overflow

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200611-20
(GNU gv: Stack overflow)


GNU gv does not properly boundary check user-supplied data before
copying it into process buffers.

Impact

A possible hacker could entice a user to open a specially crafted document
with GNU gv and execute arbitrary code with the rights of the user on
the system.

Workaround

There is no known workaround at this time.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-5864


Solution:
All gv users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/gv-3.6.2-r1"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2006 Michel Arboi

Cables, Connectors

Intel Xeon E5-2658 8-Core 2.1GHz 20MB 8GT/s SR0LZ CPU Server Processor
$35.0
Intel Xeon E5-2658 8-Core 2.1GHz 20MB 8GT/s SR0LZ CPU Server Processor pictureLENOVO THINKSERVER RD540 E5-2603V2 1.80GHZ 48GB 3 X 800GB SSD
$1899.0
LENOVO THINKSERVER RD540 E5-2603V2 1.80GHZ 48GB 3 X 800GB SSD pictureDELL POWEREDGE R730 8 BAY TWO E5-2640V4 2.4GHZ 768GB 6 X 800GB SSD H730
$12919.0
DELL POWEREDGE R730 8 BAY TWO E5-2640V4 2.4GHZ 768GB 6 X 800GB SSD H730 picture


Discussions

No Discussions have been posted on this vulnerability.