Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200606-07] Vixie Cron: Privilege Escalation


Vulnerability Assessment Details

[GLSA-200606-07] Vixie Cron: Privilege Escalation

Vulnerability Assessment Summary
Vixie Cron: Privilege Escalation

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200606-07
(Vixie Cron: Privilege Escalation)


Roman Veretelnikov discovered that Vixie Cron fails to properly
check whether it can drop rights accordingly if setuid() in
do_command.c fails due to a user exceeding assigned resource limits.

Impact

Local users can execute code with root rights by deliberately
exceeding their assigned resource limits and then starting a command
through Vixie Cron. This requires resource limits to be in place on the
machine.

Workaround

There is no known workaround at this time.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2607


Solution:
All Vixie Cron users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-process/vixie-cron-4.1-r9"


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2006 Michel Arboi

Cables, Connectors

Dell PowerEdge R710 2x X5570 2.93GHz Quad Core 16GB 8x 146GB 15K SAS PERC 6/i
$505.0
Dell PowerEdge R710 2x X5570 2.93GHz Quad Core 16GB 8x 146GB 15K SAS PERC 6/i pictureIntel E1G44HT 82580 PCI-E Quad Ports Network Server Adapter Card I340-T4 Nic
$44.95
Intel E1G44HT 82580 PCI-E Quad Ports Network Server Adapter Card I340-T4  Nic pictureDell PowerEdge R410 2x X5570 2.93GHz Quad Core 16GB 4x 2TB 7.2K SATA PERC 6/i
$795.0
Dell PowerEdge R410 2x X5570 2.93GHz Quad Core 16GB 4x 2TB 7.2K SATA PERC 6/i pictureDell PowerEdge R510 2x L5640 2.26GHz 6 Core 64GB 12x 1TB 7.2K SATA PERC H700
$1395.0
Dell PowerEdge R510 2x L5640 2.26GHz 6 Core 64GB 12x 1TB 7.2K SATA PERC H700 picture


Discussions

No Discussions have been posted on this vulnerability.