Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200601-01] pinentry: Local privilege escalation


Vulnerability Assessment Details

[GLSA-200601-01] pinentry: Local privilege escalation

Vulnerability Assessment Summary
pinentry: Local privilege escalation

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200601-01
(pinentry: Local privilege escalation)


Tavis Ormandy of the Gentoo Linux Security Audit Team has
discovered that the pinentry ebuild incorrectly sets the permissions of
the pinentry binaries upon installation, so that the sgid bit is set
making them execute with the rights of group ID 0.

Impact

A user of pinentry could potentially read and overwrite files with
a group ID of 0.

Workaround

There is no known workaround at this time.


Solution:
All pinentry users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-crypt/pinentry-0.7.2-r2"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2006 Michel Arboi

Cables, Connectors

HP ProLiant DL380P G8 2x Six Core 2.90Ghz E5-2667 96GB RAM -No HDD's- 2x 750W PS
$292.0
HP ProLiant DL380P G8 2x Six Core 2.90Ghz E5-2667 96GB RAM -No HDD's- 2x 750W PS picture iMAC A1419 27" LATE 2012.. 32GB..RAM..1TB HDD.. i5 3.2GHz..OS MOJAVE..675MX 1G
$769.49
 iMAC A1419 27Crucial 16GB 4x4GB PC3-12800 DDR3 Dell Optiplex 790 780 580 990 980 380 Memory *
$74.8
Crucial 16GB 4x4GB PC3-12800 DDR3 Dell Optiplex 790 780 580 990 980 380 Memory * picture


Discussions

No Discussions have been posted on this vulnerability.