Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200512-14] NBD Tools: Buffer overflow in NBD server


Vulnerability Assessment Details

[GLSA-200512-14] NBD Tools: Buffer overflow in NBD server

Vulnerability Assessment Summary
NBD Tools: Buffer overflow in NBD server

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200512-14
(NBD Tools: Buffer overflow in NBD server)


Kurt Fitzner discovered that the NBD server allocates a request
buffer that fails to take into account the size of the reply header.

Impact

A remote attacker could send a malicious request that can result
in the execution of arbitrary code with the rights of the NBD server.

Workaround

There is no known workaround at this time.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3534


Solution:
All NBD Tools users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-block/nbd-2.8.2-r1"


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

Cisco PIX 515E Firewall Security Appliance
$9.99
Cisco PIX 515E Firewall Security Appliance pictureCisco ASA5520-BUN-K9 ASA 5520 Security Appliance Firewall 4GE 1FE 3DES/AES
$120.0
Cisco ASA5520-BUN-K9 ASA 5520 Security Appliance Firewall 4GE 1FE 3DES/AES pictureMcAfee VirusScan Plus 2007 Anti-Virus, Antispyware, and Firewall software
$10.0
McAfee VirusScan Plus 2007 Anti-Virus, Antispyware, and Firewall software pictureCisco ASA 5505 V03 Series Adaptive Security
$49.99
Cisco ASA 5505 V03 Series Adaptive Security picture


Discussions

No Discussions have been posted on this vulnerability.