Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200505-13] FreeRADIUS: SQL injection and Denial of Service vulnerability


Vulnerability Assessment Details

[GLSA-200505-13] FreeRADIUS: SQL injection and Denial of Service vulnerability

Vulnerability Assessment Summary
FreeRADIUS: SQL injection and Denial of Service vulnerability

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200505-13
(FreeRADIUS: SQL injection and Denial of Service vulnerability)


Primoz Bratanic discovered that the sql_escape_func function of
FreeRADIUS may be vulnerable to a buffer overflow (BID 13541). He also
discovered that FreeRADIUS fails to sanitize user-input before using it
in a SQL query, possibly permiting SQL command injection (BID 13540).

Impact

By supplying carefully crafted input, a malicious user could cause an
SQL injection or a buffer overflow, possibly leading to the disclosure
and the modification of sensitive data or Denial of Service by crashing
the server.

Workaround

There are no known workarounds at this time.

References:
http://www.securityfocus.com/bid/13540/
http://www.securityfocus.com/bid/13541/


Solution:
All FreeRADIUS users should upgrade to the latest available version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dialup/freeradius-1.0.2-r4"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

IBM Server System x3250 M3 Server Intel Xeon
$99.95
IBM Server System x3250 M3  Server Intel Xeon pictureHP DL380p G8 16-Core Server 2x E5-2670 2.6GHz 192GB-16 SFF 8 Bay with 2x1TB HD
$599.0
HP DL380p G8 16-Core Server 2x E5-2670 2.6GHz 192GB-16 SFF 8 Bay with 2x1TB HD pictureIntel Xeon Processor E5-2673 V3  25MB cache, 3.3 GHz, 8 core, 768GB, scalable 
$400.0
Intel Xeon Processor E5-2673 V3  25MB cache, 3.3 GHz, 8 core, 768GB, scalable  pictureHP DL360 G7 1U (12-Core) - 2x Xeon X5650@ 2.67GHz 8GB PC3 No HDD P410i 2.5"+
$181.39
HP DL360 G7 1U (12-Core) - 2x Xeon X5650@ 2.67GHz 8GB PC3 No HDD P410i 2.5


Discussions

No Discussions have been posted on this vulnerability.