Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200503-08] OpenMotif, LessTif: New libXpm buffer overflows


Vulnerability Assessment Details

[GLSA-200503-08] OpenMotif, LessTif: New libXpm buffer overflows

Vulnerability Assessment Summary
OpenMotif, LessTif: New libXpm buffer overflows

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200503-08
(OpenMotif, LessTif: New libXpm buffer overflows)


Chris Gilbert discovered potentially exploitable buffer overflow
cases in libXpm that weren't fixed in previous libXpm security
advisories.

Impact

A carefully-crafted XPM file could crash applications making use
of the OpenMotif or LessTif toolkits, potentially permiting the
execution of arbitrary code with the rights of the user running the
application.

Workaround

There is no known workaround at this time.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0605


Solution:
All OpenMotif users should upgrade to an unaffected version:
# emerge --sync
# emerge --ask --oneshot --verbose x11-libs/openmotif
All LessTif users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-libs/lesstif-0.94.0-r2"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

AMD FD8350FRHKBOX FX-8350 FX-Series 8-Core Black Edition Processor
$9.96
AMD FD8350FRHKBOX FX-8350 FX-Series 8-Core Black Edition Processor pictureDell PowerEdge R720xd 2x E5-2640 v2 2.0GHz 8 Core 96GB 12x 3TB 7.2K SAS H710P
$2527.9
Dell PowerEdge R720xd 2x E5-2640 v2 2.0GHz 8 Core 96GB 12x 3TB 7.2K SAS H710P pictureDell PowerEdge R710 2x L5640 2.26GHz 6 Core 16GB 8x 600GB 10K SAS PERC 6/i
$1210.5
Dell PowerEdge R710 2x L5640 2.26GHz 6 Core 16GB 8x 600GB 10K SAS PERC 6/i pictureDell Latitude E6530 Intel Core i7 3720QM 2.6GHz 8GB 500GB No OS No Battery 13584
$149.99
Dell Latitude E6530 Intel Core i7 3720QM 2.6GHz 8GB 500GB No OS No Battery 13584 picture


Discussions

No Discussions have been posted on this vulnerability.