Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200502-08] PostgreSQL: Multiple vulnerabilities


Vulnerability Assessment Details

[GLSA-200502-08] PostgreSQL: Multiple vulnerabilities

Vulnerability Assessment Summary
PostgreSQL: Multiple vulnerabilities

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200502-08
(PostgreSQL: Multiple vulnerabilities)


PostgreSQL's contains several vulnerabilities:
John Heasman discovered that the LOAD extension is vulnerable to
local privilege escalation (CVE-2005-0227).
It is possible to bypass the EXECUTE permission check for functions
(CVE-2005-0244).
The PL/PgSQL parser is vulnerable to heap-based buffer overflow
(CVE-2005-0244).
The intagg contrib module is vulnerable to a Denial of Service
(CVE-2005-0246).

Impact

A possible hacker could exploit this to execute arbitrary code with the
rights of the PostgreSQL server, bypass security restrictions and
crash the server.

Workaround

There is no know workaround at this time.

References:
http://archives.postgresql.org/pgsql-announce/2005-02/msg00000.php
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0227
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0244
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0245
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0246


Solution:
All PostgreSQL users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-7.4.7"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

DELL POWEREDGE M620 BLADE TWO E5-2630LV2 2.40GHZ 48GB 600GB 15K SAS H710
$1499.0
DELL POWEREDGE M620 BLADE TWO E5-2630LV2 2.40GHZ 48GB 600GB 15K SAS H710 pictureLot (8) HP ProLiant BL460c G8 2x E5-2640 2.5GHz 6-Core 554FLB P220i 512MB Cache
$2000.0
Lot (8) HP ProLiant BL460c G8 2x E5-2640 2.5GHz 6-Core 554FLB P220i 512MB Cache pictureDELL POWEREDGE M620 BLADE TWO E5-2630LV2 2.40GHZ 48GB 2 X 1.6TB SSD H710P
$3059.0
DELL POWEREDGE M620 BLADE TWO E5-2630LV2 2.40GHZ 48GB 2 X 1.6TB SSD H710P pictureDELL POWEREDGE M630 TWO E5-2667V3 3.2GHZ 128GB 1TB SATA S130
$5909.0
DELL POWEREDGE M630 TWO E5-2667V3 3.2GHZ 128GB 1TB SATA S130 picture


Discussions

No Discussions have been posted on this vulnerability.