Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200411-14] Kaffeine, gxine: Remotely exploitable buffer overflow


Vulnerability Assessment Details

[GLSA-200411-14] Kaffeine, gxine: Remotely exploitable buffer overflow

Vulnerability Assessment Summary
Kaffeine, gxine: Remotely exploitable buffer overflow

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200411-14
(Kaffeine, gxine: Remotely exploitable buffer overflow)


KF of Secure Network Operations has discovered an overflow that occurs during the Content-Type header processing of Kaffeine. The vulnerable code in Kaffeine is reused from gxine, making gxine vulnerable as well.

Impact

A possible hacker could create a specially-crafted Content-type header from a malicious HTTP server, and crash a user's instance of Kaffeine or gxine, potentially permiting the execution of arbitrary code.

Workaround

There is no known workaround at this time.

References:
http://securitytracker.com/alerts/2004/Oct/1011936.html
http://sourceforge.net/tracker/index.php?func=detail&aid=1060299&group_id=9655&atid=109655


Solution:
All Kaffeine users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/kaffeine-0.4.3b-r1"
All gxine users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/gxine-0.3.3-r1"


Network Security Threat Level: Medium


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

iBUYPOWER Desktop Computer NE740RAi Intel Core i5 7th Gen 7400 (3.00 GHz) 8 GB D
$829.99
iBUYPOWER Desktop Computer NE740RAi Intel Core i5 7th Gen 7400 (3.00 GHz) 8 GB D pictureAsus Q503U 2-in-1 FHD Touch 6th Gen. Intel Core i5-6200U 2.40 GHz 8gb 1TB HDD
$1.0
Asus Q503U 2-in-1 FHD Touch 6th Gen. Intel Core i5-6200U 2.40 GHz 8gb 1TB HDD pictureDell PowerEdge R730 2x E5-2660v3 2.6GHz 10 Core 256GB 8x 300GB 15K SAS H730 RAID
$6725.0
Dell PowerEdge R730 2x E5-2660v3 2.6GHz 10 Core 256GB 8x 300GB 15K SAS H730 RAID pictureDell PowerEdge R620 2x E5-2650 v2 2.6GHz 8 Core 32GB 8x 600GB 10K SAS PERC H710
$3025.0
Dell PowerEdge R620 2x E5-2650 v2 2.6GHz 8 Core 32GB 8x 600GB 10K SAS PERC H710 picture


Discussions

No Discussions have been posted on this vulnerability.